Pular para o conteúdo
Ver todas as ameaças

CVE-2024-3054

Alvo: Não informado

Descrição

WPvivid Backup & Migration Plugin for WordPress is vulnerable to PHAR Deserialization in all versions up to, and including, 0.9.99 via deserialization of untrusted input at the wpvividstg_get_custom_exclude_path_free action. This is due to the plugin not providing sufficient path validation on the tree_node[node][id] parameter. This makes it possible for authenticated attackers, with admin-level access and above, to call files using a PHAR wrapper that will deserialize the data and call arbitrary PHP Objects. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

Software
Não informado
Tipo Software
Plugin
CVE
CVE-2024-3054
Tags
Nâo informado
Data de publicação
12/04/2024
Última atualização
13/04/2024
Pontuação em CVSS 3.0
7.2
Alto
plugins premium WordPress