Pular para o conteúdo
Ver todas as ameaças

CVE-2019-19589

Alvo: Não informado

Descrição

The Lever PDF Embedder plugin 4.4 for WordPress does not block the distribution of polyglot PDF documents that are valid JAR archives. Note: It has been argued that “The vulnerability reported in PDF Embedder Plugin is not valid as the plugin itself doesn’t control or manage the file upload process. It only serves the uploaded PDF files and the responsibility of uploading PDF file remains with the Site owner of WordPress installation, the upload of PDF file is managed by WordPress core and not by PDF Embedder Plugin. Control & block of polyglot file is required to be taken care at the time of upload, not on showing the file. Moreover, the reference mentions retrieving the files from the browser cache and manually renaming it to jar for executing the file. That refers to a two step non-connected steps which has nothing to do with PDF Embedder.

Software
Não informado
Tipo Software
Plugin
CVE
CVE-2019-19589
Tags
Nâo informado
Data de publicação
05/12/2019
Última atualização
08/11/2023
Pontuação em CVSS 3.0
9.8
Crítico
plugins premium WordPress